inca|yellow

Back at the pumps

With the MOT passed and the road tax paid we took it out for a celebratory run and it's first visit to the pumps in a while.

We clocked about 16 miles, keeping to around 50mph until we're sure everything is working ok. Worth a quick note about petrol - although the MG is designed to run on leaded fuel, it seems that standard unleaded, even without any additional additives, is quite alright. One of the theories is that the years of use of leaded fuel has created a protective layer which will keep any harm coming to the engine pretty much for the rest of its life. Some people swear by Shell Optimax's higher octane levels, but an equal number seem to be quite happy with run-of-the-mill supermarket 95. Either way there are plenty of people who have run their MGBs on unleaded without any ill effects.

We did notice that the fan doesn't seem to come on as early as it probably should, so I've ordered a new switch and as the gauge seems to hardly move, even after idling, I've also ordered a new thermal transmitter. The only other thing to come out of this run was that the front left indicator failed, probably due to the vibration, so we'll need to remove the horn and get back into that wiring.

All in all it was a good run out - next up, having a go with the overdrive!

categories: see more posts related to driving see more posts related to electrics

Comments

  1. Christopher said on 31 Mar 2009:

    Well done! You must be very proud. Ta, Chris
  2. Adam said on 31 Mar 2009:

    Thanks Chris. Yes, and it's really nice to see it on the road. Just thinking of lots of summer driving at the moment!